
Dreamweaver CS6 

 

 

  
In this unit we will investigate: 

• the Dreamweaver interface and layout 

• using HTML 

• entering and formatting text in a web page 

• setting up links 

• using style sheets 

• inserting and positioning images  

• site creation and navigation 

• publishing a site 

• tables 

• templates. 

Note: prior to use these activities require Dreamweaver to be configured for student use; the 

setup procedure and required files can be found at the end of these activities 



Activity 1 – A first look at Dreamweaver 
Adobe Dreamweaver CS6 is a professional authoring tool used to create web pages. When ready these pages can 
then be published to a network or internet site that others can visit.  

In this first look we will find out about the Dreamweaver interface, and use it to investigate an existing site.  

Note: this activity and those that follow assume Dreamweaver has been set up for student use. For directions on how 
to do this see Dreamweaver CS6 Setup at the end of these activities.  

1. We will start by looking at an imaginary web site for SpongeBob Squarepants. 

a Start Dreamweaver. 

 Note: the screenshots used in these activities are from a Windows PC; if 
using a Macintosh computer your screen may vary slightly. 

b In the Files panel at right, double click on index.htm. (Note: if you cannot see 
the Files panel or its contents press the F8 function key on your keyboard 
once.) 

 The page index.htm will be opened for ready for editing. This is the home 
page the site. 

c To see the sbsp web site in action click on the preview button on the toolbar 
and choose a browser. 

           

 This will jump out of Dreamweaver and will start the browser you select with the sbsp web site displayed. 

 

 Spend a few minutes using the links to look around the site. In particular be aware of the actions of buttons 
and links to jump to other pages. 

 Note: the shortcut to preview a site in a browser is to use the F12 function key. This will display the site in 
your default browser. If you use Ctrl+F12 (PC) or Cmd+F12 (Mac) you will see the site in a secondary 
browser (IExplore above). 

d Close the browser and return to Dreamweaver. 



2. At this stage we will take a broad look at the Dreamweaver interface and its layout. 

 

a Across the top of the display is a menu and a toolbar of common actions. 

 

The toolbar can be made a little more attractive if you enable colored icons. To do this from the menu 
choose View > Color Icons. 

If you wish you can add a standard toolbar (View > Toolbars > Standard) that has icons for New, Open, Save, 
and so on. 

 

b The majority of the interface is taken up with the Document window. This is where web pages can be 
prepared. 

To assist with layout you can have rulers displayed around the document window (View > Rulers > Show). 
These can be set to pixels or inches. 

c On the toolbar above the document window are buttons for Code, Split, Design and Live.  

 Design is where the web page is laid out, Code shows the HTML behind the page (see next activity), while 
Split will show both at once.  

 Live view is a way of seeing the page in action without having to run the browser as we did in 1c above.  

 Try each of these, but return to Design view. 
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d Below the document window is the Properties inspector which can be used to vary the appearance and 
behavior of objects on the web page. The information displayed will change depending on which object is 
selected.  

The site as shown on the previous page has the HTML properties inspector displayed. To change to the CSS 
properties inspector click on the CSS button at left. 

 

(We will use the CCS properties inspector in later activities.) 

d Finally at right are a group of panels for specialist actions. Some, like Assets or AP Elements, are on panel 
tabs. 

 

Each of these panels can be expanded or shrunk by double clicking on its tab. For example in the image 
above the File/Assets panel is displayed with Assets selected, while the remaining panels have been shrunk. 

Each panel (and the property inspector) also has a menu button  at the right of its title bar. 

There are more panels available than those displayed. To access these use the Window menu. 

 Note: for ways to customize the Dreamweaver interface see Follow up at the end of this activity. 

3. The Files panel shows folders and the web pages, images, and other objects that make up the website. 

a Double click on one of the pages in the files panel at right.  

 This will open the page in a separate document window to index.html. 

 

 Repeat until you have three or four pages open. 

 You can use the tabs on these pages to move between them. 

b From the menu try Window > Cascade. 

 Try also Window > Tile Horizontally (or Tile Vertically). 

 To return the pages to tabbed mode click the maximize icon  at the top right of any page.  

4. We will now add a new page to this site. This page will display three pictures with captions from the SpongeBob 
movie. 

a Choose File > New from the menu. 

 So that the new page looks like the others we will use the sbsp template. 



 In the dialogue that appears choose Page from Template and then from the sbsp site choose the 
sbsp_template.  

  

 When ready click Create and a new page called Untitled-1 will appear in the document window. 

b On the toolbar of this page click in the Title box and rename it Movie.  

             

 Page titles are easier to remember and use than file names. The page title will also be displayed in the title 
bar and page tab when the page is opened in a browser. 

     

c Save the page as movie.html in the sbsp folder. 

 You will see it appear in the files panel.  

   

 Note: if the file does not appear automatically click on the Refresh button at the top of the files panel (or 
press the F5 function key). 

d View the page in the browser (F12). 

5. Next we will add some images to this page. 

a In Dreamweaver in the files panel open the images folder and then the movie folder. 

 

 These are pictures from the movie. 
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b Click once on any of the images to select it, and then drag it onto the page in the document window so that 
it is positioned in the main section. 

 

 If you are prompted to add alternate text (Image Tag Accessibility) choose Cancel at this stage. (The use of 
alternate text will be explained in Activity 4.) 

 If you do not want this particular image press Delete while it is still selected. 

c Click once on the image to select it and use the image handles to resize the picture to a smaller size. 

 Hint: if you hold down the Shift key as you do this, the picture will resize in proportion. 

 You can see that the size of the image in kilobytes (K) and pixels is shown in the properties inspector, along 
with a Reset Size button.  

 

 The reset button will return the picture to its original size. 

d Click just past the image (to deselect it) and press Enter to move to a new line.  

 Type a caption for the image. Do not worry about the font, color or size of the text at this time. 

 When ready press Enter to move to a new line. 

e We will now add more images to the page, but this time we will be able to see them before we select them. 

 At the top of the files panel, click on the Assets tab. 

 

 The Assets panel is used to catalogue items used in the web site. It includes things like images, colors, Flash 
animations, hyperlinks, etc. The advantage for us in this case is that we will be able to see a preview of any 
of the images we might like to use. 

  

 Choose a second and third image to add to the page. (sbsp 9, 10, 12, 13, 14 and 16 are from the movie.) 

 Drag them from the assets panel to the document window under the earlier picture, and caption each. 
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f The asterisk next to a file name on the page tab is a reminder that you have made changes to a page since it 
was last saved.  

 

 Re-save the page.  

g Return to the browser and press the Refresh button to see the changes made. 

 Note: it is necessary to save a page before viewing it in the browser. If you do not, the browser will just 
display the last saved version of the page without any changes you have made since. 

6. We can now make a link to this page from the home page. 

a Use the page tabs in the document window to move to the home page (index.htm). 

b In the files panel open the buttons folder and find the movie.gif button. 

   

 From this folder drag movie.gif  to just under the other buttons. (Again ignore the accessibility attribute 
option.) 

c We will now create a hyperlink from this button image to the movie page we created. 

 In the properties inspector at the bottom find the Link box. 

 Next to this is a Point to File icon. 

   

 While the movie button is still selected, click on this point to file icon, hold the mouse button down, and 
drag across to the files panel to point at the file movie.html. (If necessary shrink the images folder first.) 

 

 This will create a hyperlink from the button to the page. 



d Save the page and test in the browser (F12). When you click on the button it will open the page you 
created. 

 Note: an alternative way to make a link is to right click on the button image, choose Make Link, and in the 
dialogue that appears choose movie.html. 

7. To finish click the Code button on the toolbar of your movie page. 

          

 As you have been making changes to the page Dreamweaver has been preparing the HTML code to go with the 
page.  

 We will explore the role of HTML in the next activity. 

 To return to the normal view click the Design button on the toolbar.  

  



Follow up – customizing the interface 
Much of the Dreamweaver workspace can be customized to suit the way you work.  

1. To make more space the side panels can be shrunk by clicking on the Collapse button  at top right. Try this. 

 The inspection panel also has an expander button to show more or less of either the HTML or the CSS panels. 

 

 

 The side panels and properties inspector can be hidden altogether by pressing the F4 function key. This is a 
toggle action. 

2. Each of the panels and the toolbar can be dragged to new positions to suit a task you are doing or to fit your 
work style. 

 To move a panel drag its tab so that it either “floats” or is docked against one side.  

 To move the toolbar drag the double line to its left. 

 

 A different range of panels can also be displayed using Window from the menu. 

3. The layout shown in the previous activity is the Designer layout for the workspace.  

 

 Using the drop down arrow on the workspace button (to the right of the menu) different layouts can be 
selected. These are various arrangements of toolbar and panels to suit specific tasks.  

 To restore everything to their original locations click on Designer  under the workspace button.  

 Note: the Reset ‘Designer’ option will return the workspace to the factory default setting. 

 

 Do not use this unless really necessary. 
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4. If you wish you can set up a workspace that suits the way you operate. To do this make your own arrangement 
of panels and toolbar, and then click on the New Workspace option.  

           

 When named your own workspace will be added to this list. 

5. The insert panel at the right contains a variety of items that can be added to a page. 

 

 Some items (such as Images or Media) have a drop down arrow with more options listed in a pop-up menu. 

 

 The categories displayed on the insert panel can be varied. 

 Use the drop down arrow at the top of the insert panel to see the different categories available. 

                             

 If you right click in the insert panel and choose Customize Favorites you can set up your own list of items that 
will appear in the Favorites list. 

 To return to the original list choose Common. 

 Note: you can also set icons to be colored by right clicking in the insert panel. 

  



Activity 2 – HTML 
Most of the information on a web page consists of plain text and instructions on how to display the text. Together 
these make HTML – hypertext markup language. The browser reads the HTML and, with graphics, presents it as a 
web page. 

So that we can understand what is happening in this process we will write some HTML of our own.  

1. a Start Notepad (Start > Programs > Accessories > Notepad).  

 Notepad is a text editor. It writes text only, with no formatting information such as font or size or spacing. 

b Write a sentence.  

  

c Use File > Save As to save the file with the extension .htm or .html in the Dreamweaver folder.  

 Note: Dreamweaver (and Windows) will work with either .htm or .html as file extensions. 

2. Open the file you have just saved in your browser. (Double click on the file in Windows Explorer.) 

The simple text sentence will be displayed in your default browser. 

                       

3. a Return to Notepad. 

b Choose one word and, using angle brackets < >, add a <b>  tag to the beginning and a </b>  tag to the end of 
it.  

 

c Re-save the text file.  

d Return to the browser and refresh the page. (IE - ; Firefox - ) 

 

 How has the word changed? 

 The <b>  tag caused what followed to be written in bold. The </b>  tag turned the bold off. 

e In Notepad change the <b>  to <i>,  and </b>  to </ i> .  

 Save and refresh in the browser. What do you think the i stands for? 

f See if you can underline a word. 

 Tags like <b>  are a way of specifying formatting in a text document. A browser can read and display this 
formatting. Tags that start with a backslash  / , switch the format off again. 

 Note: it is necessary to save after each change before refreshing the page in the browser. If changes have 
not been saved the browser will just display the page as it was. 

4. a In Notepad insert a title on the line above your sentence.  

b Add <h1>  and </h1>  tags around the title.  

 

 h1 stands for Heading style 1. 



c Save and refresh in the browser. 

d Try changing each h1 to h2 or h3 and see how the display changes. 

e At the end of the title add an <hr/>  tag (no closing tag). 

 What do you think hr might stand for? 

5. a In Notepad add the following (be careful with the spaces):  

 <img src = “swagman.jpg”> 

b Save and refresh in the browser. 

6. a Finally return to the sbsp site in Dreamweaver. 

b If necessary choose the Code button on the toolbar of your Movie page. 

 Find the HTML for inserting the images onto the page. 

 

 What other information has been included in these image tags?  

 See if you can include similar information in the HTML you wrote in NotePad, or alternately add an hr tag to 
the code of your Movie page. 

  



Activity 3 – Words with style 
Shortly we will look at how to make a whole web site, but before we get to that let’s look at simply setting up a single 
web page and adding content to it. We will see how to enter the text of the page and how to apply HTML and style 
rules to format it. 

To do this we will make a single page with information for a sports’ store. 

1. a In Dreamweaver close any pages that might be open. (Click on  on each page tab, or use File > Close All.) 

b Use the Files panel to switch to the Sports Store site.  

 

 This is a site with no pages yet, just some images and text ready to be used. 

c Create a new blank HTML page. 

 This can be done from the Welcome screen by choosing HTML under Create New. 

 

 If the Welcome screen is not displayed (it can be turned off in Edit > Preferences) then from the menu use 
File > New. In the dialogue that appears choose a Blank Page, HTML page type and <none> for layout. When 
ready click on Create at lower right. 

 

d Give the page the title of Sports and save it as sports.html. 

 

 The page will appear in the Files panel in the Sports Store root folder. 

 

 Note: it is important that all of the files, images and resources used in a site are kept in the one folder. This 
is so that when the site is published to a web server they are all available from the one location. 



2. We will now add text to this page. This can be done in three ways, typing directly into the document window, 
importing text, or with a cut and paste from another application.  

We will use each of these methods in turn to demonstrate. 

a The easiest, but slowest, way of getting text on a page is to enter it directly. 

 Make up your own name for the sports’ store and type it in the document window.  

 

 Do not worry about formatting this title yet, we will get to that shortly. 

b While we can type directly into the document window this will take some effort. To save time we will now 
to import some pre-prepared text on sale items for the sports’ store. 

 Click just after your title and press Enter to move to a new line.  

 Drag the file sale.txt from the files panel onto the document window. Position it 
just under the store name, and release it. 

 When prompted to insert the contents click OK. (Accept the default of Text with 
structure.) 

                       

 The text from the file will be placed under the title. 

c The third way we can enter text into the document window is to copy it from another application. We will 
copy some text from Word. 

 Start Word and, from the Sports Store folder, open the file Special offer.docx. 

 

 This is text formatted using bold, italics, a Comic Sans font, and different sized letters. 

 Select all of the text (Ctrl+A on a PC; Cmd+A on a Mac) and copy it (Ctrl+C or Cmd+C)).  

 Switch back to Dreamweaver and move to a new line under the sale items. 

 If we paste now we will get an exact copy of the Word document. As we do not want the formatting that is 
in the document we will copy just the text. 

 From the menu (or with a right click) choose Edit > Paste Special... to see the options available. 

 



 Choose Text only and click on OK.  

 
 The text without formatting has been placed in our web page. 

d Re-save the page. 

 Note: the three methods of adding text to a page just described are direct typing, dragging a txt file onto 
the page, or a copy and paste from a different application. When preparing your own web pages you can 
choose the method most suitable for your task. 

3. We will now spread the text out on the page with paragraph and line breaks. 

a Click just in front of the The after Special offer and press Enter to put it on a line by itself. 

 Next move to the bottom paragraph and at the beginning of the second sentence (In addition...) press 
Enter. 

 These two actions insert paragraph breaks in the text.  

 

 As you can see a line of space is automatically added between paragraphs. 

b If you do not want space between paragraphs it is necessary to insert a line break. 

 Move to the beginning of the third sentence (Be early ....), but this time hold down Shift as you press Enter.  

 

 The sentence moves to a new line, but without the in-between space. 

 (If you use the Code or Split button to check the HTML you will see the different tags used for these.) 

c Finally add a full paragraph break between the last two sentences. 

d At this point re-save the page and view it in the browser (F12). 

 This page is now ready for us to experiment with. Over the next few exercises we will return to the page in 
this state. 

4. Now that we have some text to work with we will format it. We can do this either by changing the HTML or by 
using a style sheet. We will start by seeing how the properties inspector can manipulate HTML to format text. 

a Use File > Save As to save the file as sports2.html. 

 

 We will make our HTML changes to this second version of the page. In this way we can still be able to come 
back to the original version (sports.html) later.  



b Check the HTML properties inspector is selected. 

 

 When this page was created Dreamweaver automatically set up the HTML to display it. 

 To see this click on the Split button at the top of the document window. 

 

 On the left HTML will be displayed, at the right the text we have entered. 

 (Note: the HTML and text can be displayed side by side like this or you can display one on top of the other. 
To toggle between the two views click on View > Split Vertically.) 

c Click anywhere in the title (Sportz World) and then in the properties inspector use the Format option to 
select Heading 1. 

    

 The title has now been formatted in a heading 1 style as we saw in the last activity. 

 Looking in the code window we can see the HTML paragraph tags <p> have been replaced by heading1 <h1> 
tags. 

   

d Use the properties inspector to convert Sale now on and Special offer to heading 2 and Gym equipment 
specials and Cricket specials to heading 3. 

 



e Now to add some bullets. 

 Select the five paragraphs under the Gym equipment specials heading.  

 In the properties inspector click on the Unordered List icon . 

  

 Tags have been added so that the text is formatted as an unordered list <ul>, with each paragraph a list 

item <li>.  

 An unordered list is more commonly described as bullets.  

 Note: an ordered list <ol> is where the lines are numbered. 

f Add bullets to the five paragraphs under Cricket specials. 

g Lines are good for organizing information or visually separating objects. 

 Click just in front of the Gym equipment specials heading. 

 From the insert panel at the right click on Horizontal Rule. 

    

 (You could of course have just added an <hr/> tag in the HTML.) 

 Add another line just above the Special offer heading. 

 Click on either of the lines and note the changes you can make to them in the properties inspector. 

h At this stage click on the Design button to return to design view alone. 

 Re-save the page, view it in the browser (F12), and then close it. This finishes our look at HTML formatting. 

5. A style sheet is a way of saving formatting information such as fonts, color, alignment, and so on. The style sheet 
can be stored with the HTML code or can be a separate file. We will now see how to use a style sheet to format 
our sports page. 

 (Further information about style sheets is included in the Follow up at the end of this activity.) 

a The changes we make in this step will be to our sports page as it was at the end of step 2 above. 

 Move to or re-open our original sports.html. 

 Use File > Save As to save this file, this time as sports3.html.  

 



b We will now create a reusable style setting in this third version of our sports store site. 

 In the properties inspector switch to the CSS properties inspector. 

 

 Select the title (Sportz World), and while Targeted Rule says <New CSS Rule> click on the Edit Rule button. 

      

 You will be prompted to create a new CSS Rule. 

 

 Name the rule sp_title, accept the other defaults, and press OK. 

 In the dialogue that appears choose a font, size, weight, and color for the title. 

         

 When ready click OK. The rule will be applied to the text you had selected (here the title). 

c We have created a style rule called .sp_title that has the font, size, weight, and color chosen. (Note that 
Dreamweaver has added a full stop at the beginning of the style name.) 

 This style rule can now be used in other parts of the document. 

 Click on the text under the title (Sale now on.) and use the drop down arrow next to Targeted Rule to 
choose this style.  

   

 The title style will be applied to this text as well.  



 Note: once you have used a style setting you can reuse it anywhere in this document. Using styles like this 
will give consistency to the appearance of web pages you create. For example all titles will be identical. 

 If you look in the HTML (Code or Split button) you will see the definition of the style. 

 

 Dreamweaver inserts a style definition like this near the top of the HTML code. 

d Click on either of the two title lines and change the color or font in the properties inspector. 

 

 Both examples of the style will change.  

 Any variation in the style rule will change all applications of the style in the document. In this way you only 
have to make the one change and each occurrence of the rule will alter and be consistent with all of the 
others. 

 Note: for more detailed changes to the style rule click on the Edit Rule button in the 
properties inspector again.  

e Re-save. 

6. We will now make three more style rules, but this time we will make them in the CSS panel at right. 

a Click on text that is not styled as a title and, if necessary, expand the CSS Styles panel by double clicking on 
its title bar. 

 

 The CSS panel can also be displayed using Window > CSS Styles or Shift+F11. 

b Click on the New CSS Rule button  at the bottom of this panel.  

 Name the style rule sp_head1. 

 Choose a font, size, color, and so on that is different to the title. 

 When ready press OK. 



c Use this .sp_head1 rule in the properties inspector to format the Sale now on and Special offer headings. 

d Make a rule for sp_head2 and use this for the other subheadings. 

e To finish we will make a style rule for the bullet text. 

 Use the New CSS Rule button to set a font, color and size for the text, calling it sp_bullet. 

 Rather than set bullet type and indent in the style rule (Block and List categories) it is easier to make the 
bulleted list from the menu with Format > List > Unordered List. 

 Apply the rule to the appropriate paragraphs. 

 Note: in the CSS properties inspector there is now a List Item button next to Page Properties where you can 
set options for the list. 

 

f Re-save and view the page in the browser (F12). 

 Note: the style rules we have created are listed in the CSS Styles panel under the All tab. These styles can 
also be used in the HTML properties panel as well as the CSS properties panel. If you switch back to the 
HTML properties panel you can still see, and use, these style rules. 

   

7. The use of styles as shown above is limited to just this one web page. If we create a new page we will have to 
recreate the styles again one by one. This is inefficient and wastes time. 

 The way around this is to use an external style sheet that can be used across multiple pages, and even multiple 
web sites.  

 We can either make our own external style sheet, or use a pre-existing one. In step 5b above we accepted the 
default of letting Dreamweaver define the style rule for just that page. 

 

 We will now create an external style sheet that can be used more widely. 

a Move to or re-open sports.html. Use File > Save As to save it as sports4.html. 

 This is our original sports page with no HTML or style rules. 

b Define a style rule for the title, but this time choose the New Style Sheet File option. 

 



 When you press OK you will be presented with a dialogue requesting a name and location for the style 
sheet. By default this will be in the folder for the Sports Store site and have the extension .css. 

 Accept these defaults, name the file sport.css and press Save. 

 The style sheet, which for now has just one rule, is stored in sport.css. This can be seen in the files panel. 

                   

c Add a second style rule for the first heading (sp_head1) as we did in step 6 above, but this time add it to the 
sport.css style sheet we have just created. 

d Add subheadings (sp_head2), bullets (sp_bullet) and even paragraph (sp_para) rules to the style sheet. Add 
each rule to sport.css. 

 Hint: you can use the Edit button in the properties inspector or Format from the menu for extra settings. 

e Resave, view in the browser, and then close sports4.html. 

8. To finish we will see how to use styles we have made in one document to make an external style sheet and then 
attach it to another web page. 

a Re-open or access both sports.html, our original sports page with no formatting, and sport3.html, the page 
with internal style rules we made in steps 5 and 6 above. 

 We will export the style rules from sport3.html to an external style sheet and then attach them to 
sports.html. 

b In sport3.html open the All tab in the CSS Styles panel at right. Under <style> you will be able to see all of 
the rules made for this document. 

 Use Ctrl+click (PC) or Cmd+click (Mac) to select each of the rules. 

   

 Right click in the selection, and from the context menu choose Move CSS Rules. 

 In the dialogue that appears choose A new style sheet. 

   

 Click OK and save the style sheet as sp_style.css in the Sports Store folder. 

 We have now taken the rules we made for the sports’ store in steps 5 and 6 and created an external style 
sheet from them, i.e. a style sheet that is independent of the page. 

c We will now import this style sheet into our original unformatted sports.html page. 



 Move to sports.html and from the bottom of the CSS Styles panel click on the Attach Style Sheet button . 

 

 Use the Browse button to find sp_style.css in the Sports Store folder and click OK. 

 All of the styles we created in steps 5 and 6 above are now available. 

 

 These rules can be used to format the text in this page. 

d Move back to sports3.html and use the Edit button on the property inspector to change the color of the 
sp_title rule. 

 When you go to sports.html you will see the title has changed here also. 

 Changing the title rule (or any other rule) in the style sheet will cause changes to all instances of the rule in 
any other document that uses it. These changes are said to cascade down through the other documents. 
(CSS stands for cascading style sheets.) 

e We can remove this style sheet and attach another if we wish. 

 In the CSS Styles panel, click on the style sheet to select it and then click on the unlink button. 

   

 Now click on the link button and this time attach the sport.css we made in step 7 above. 

 In this way we can attach any style sheet we wish to a page. 

f Resave sports3.html. We will continue on with this page in the next activity. 

 Note: Dreamweaver also comes with some basic style sheets that you can attach when you create a new 
page. To do this in the new document dialogue choose Page from sample and view the CSS style sheets 
available. 

 



Follow up 

CSS 
A cascading style sheet (CSS) is a preset way of presenting layout, color and fonts, that can be saved separately from 
a web page. Styles can be used for headings, ordinary paragraphs, bullets, images, backgrounds, positioning items on 
a page, and so on. 

The fundamental concept behind CSS is that the presentation of a page or site is kept separate from its content. 

 

 

 

 

 

 

 page presentation page content 

In this way the one style sheet can be applied to a range of pages. 

This separation of presentation from content has four advantages: 

• consistency – there is a uniform appearance across all of the pages; each bullet point, each heading and 
each paragraph will look the same  

• efficiency – if you wish to make any change to formatting, the only change that has to be made is in the 
style sheet; this one change will automatically apply (or cascade through) to all pages that use it 

• smaller file size – as the formatting information is stored in one place this avoids repetition; each individual 
page can be smaller and take less time to download 

• increased control and flexibility – by localizing the specification of presentation characteristics to one file, 
management is more direct and adaptable. 

Cascading style sheets can be prepared from within a web page, as we did in this activity, by creating rules as we go 
and saving, or a CSS can be written from scratch (File > New > CSS). Dreamweaver Help will explain how to design 
your own CSS if you wish to do so. 

Alternatives to CSS 
In addition to cascading style sheets we could use an internal style sheet, or inline styles.  

An internal style sheet is formatting information for an individual page. Internal style rules are recorded near the top 
of the HTML code in the <head> section (see step 4e above).  

 

They indicate how this individual page is to be displayed. 

Inline styles vary an HTML tag for an individual element of a page, e.g. 

 <p style="font-family:times; color:green">.  

These style variations are stored as part of the normal HTML code. Inline styles are rarely used nowadays other than 
to define how a specific item is to be displayed.  
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Of the three (CSS, internal, or inline styles) cascading style sheets are the best to use, especially if you are making 
more than one web page. 

Fonts 
In setting style rules, or using the formatting generally, you may have noticed that you do not have as much choice in 
fonts in Dreamweaver as you would have in other programs, such as Word. The reason for this is that there is no 
guarantee that the font you choose on the computer to create a page will be available on the computer the page is 
seen on. This gives you less control of the final appearance, and even layout, of a page as it will appear on other 
computers.  

Dreamweaver only offers the most commonly available fonts. 

 

In the example highlighted above the browser that views your webpage will try to apply the Verdana font. If that is 
not available it will try for Geneva or, failing that, any other available san serif font.  

In this way you will have a good chance of any browser on any computer presenting text as you had hoped to display 
it. 

  



Activity 4 – Picture this 
A web page based on text alone is not very attractive. In this activity we will look at how to add backgrounds and 
images to a page. We will continue with our sports’ store page from the last activity. 

1. To improve the visual impact of the page we will start with backgrounds. 

a If necessary access or re-open sports3.html.  

 In the properties inspector click on the Page Properties button. 

 (If you cannot see page properties button make sure you are in the HTML properties inspector and that the 
expander button has been activated.) 

   

 In the Appearance category you will see you can choose a background color for this page. 

 Choose a color and when ready click Apply then OK. 

b As an alternative you can set an image as background for a page. 

 Click on the Page Properties button again, but this time choose Background image. 

 

 Browse to the Sports Store folder and choose tropical.jpg.  

 When ready click Apply, then OK. 

 (If you later wish to remove the image delete the link in the Background image box in the properties 
inspector. ) 

c Decide on the background you would like for this page, if any, and re-save. 

 Note: always take great care in using background colors or images. They should not distract anyone reading 
the page, and it should be easy to read any text against the chosen background.  

2. Now to add some images. 

a In the Files panel move to the Assets tab and, if necessary, click on the Site option. 

 

b Click on each image in turn to see a preview of it. 



c Pick an image and drag it next to the heading Special offer and release. 

   

 Dreamweaver will suggest you add Image Tag Accessibility Attributes. 

 This is an option to add Alternate text to the image. This alternate text will be used by vision-impaired users 
who employ text-to-speech software. It is also used in browsers with images turned off to save bandwidth, 
or by users with a very small screen such as an iPhone or PDA. (The reminder to add alternate text can be 
turned off if you wish in Edit > Preferences, and the text added later in the properties inspector.) 

 Add alternate text if you wish and press OK. The image will appear next to the heading. 

 Note: the properties inspector has changed to reflect that a picture is currently selected. 

 

d Use the Shift key and the corner handle at the lower right of the image to make it smaller. (The Shift key 
keeps the image in proportion.) 

          

 The changed size is shown in the properties inspector. The reset size button can be used to return the 
image to its original dimensions. 

e At the moment the image is in the Default alignment. 

 Use the Align box in the properties inspector to change alignment to Left. 

   

 The image will move to the left of the window and text will wrap around it. 

f If the text overlaps the image, or is too close to it, increase the H Space in the properties inspector to 20 or 
so pixels. 

                        

 This adds a padding of 20 pixels around the left and right sides of the image. 

reset 
size 



g Add another image higher up the page, but his time align it to the right. 

 Note: there are other align options but Left and Right are the two most commonly used. 

h Re-save. 

3. A rollover is an image that, when viewed in a browser, changes when the mouse moves across it. You can also 
use the rollover as a hyperlink to another page or site. 

a Move to just after the last of the text. 

b On the Insert panel use the drop down arrow next to Images to select Rollover Image (or from the menu 
choose Insert > Image Objects > Rollover Image). 

 Note: if you cannot find Images make sure you are using Common panel in the Insert panel. 

 In the dialogue that appears browse for two images. There are images in the Sports store/images folder. 

       

 (The preload option is to download the second image at the same time as the first so that there is no delay 
in accessing the second.) 

c Save and test in the browser. 

 As your mouse moves over the image it will change. If you click on it, you will be taken to the URL link 
specified (if it exists). 

  



Follow up – images 
Many different types of graphic file formats exist, but GIF and JPEG are the most commonly used for web pages and 
can be viewed by most browsers. 

GIF files (.gif extension) have a maximum of just 256 colors. Gifs are best for displaying areas of flat colors such as 
navigation bars, buttons, icons, logos, or other images with little variation in color or tone. You can also easily specify 
a transparent color in a gif so that the background can be seen through. 

     

 gif jpg 

The JPEG file format (.jpg extension) can contain millions of colors and is best for photographic images.  

The better the quality of a JPEG, the larger file size and, in turn, the time needed to download it. For display on a 
computer screen the quality of a photograph does not have to be too high and so it is best to optimize images so that 
they take up as little bandwidth as possible. To do this, in Dreamweaver right click on any JPEG image you use and 
choose Optimize... from the context menu. 

Note: you can also use Fireworks or Photoshop to optimize images. 

  



Activity 5 – Navigation 
Now that we have seen how to develop web pages it is time to see how to put them together in a web site and find 
out how to move between them in a process called navigation. In this activity we will develop a simple web site for a 
school. 

In building a site it is important to have a clear idea how the different pages will link together. The site plan we will 
use looks like this: 

 
 
 
 
 
 
 
 
 
 
 
 
 
This simplistic site has just three levels and six pages, and is used only to demonstrate the processes involved. Once 
the site framework is set up however, it could easily be extended by adding more pages.  

A page that has other pages at a lower level is called a parent page, the ones at a lower level are the child pages. In 
the site above Curriculum is parent to the child pages Staff and Subjects. 

Dreamweaver can manage as many web sites as you wish, but each site must have its own name and have its own 
folder on your local computer to store files. A School folder with an Images subfolder should have already been 
created for this in the Dreamweaver folder (see setup).  

1. Firstly we will define the site. 

a Close any open pages and then from the menu choose Site > New Site ...  

 (You could also choose Dreamweaver Site under Create New in the Welcome screen.) 

b In Advanced Settings name the site School and use the browse button  to set the Local Site Folder.  

 

c When ready click on Save and Dreamweaver will set up the site. 

 This can be seen in the Files panel. 

 Note: to return to the above dialogue to make any changes, from the menu 
choose Site > Manage Sites, and then select Edit. Alternately you can just 
double click on School in the files panel. 

Home 

Students Curriculum News 

Staff Subjects 



2. Once the site is defined create the home page. A home page is the first page visitors to a site see, and is the root 
of the tree structure of the site. 

a From the menu use File > New to create a blank HTML page as we did in Activity 3. 

 

b Save this page to the School folder calling it index. 

 Dreamweaver will automatically add an .html extension onto this file and it should appear in the files panel. 
(If it does not click the Refresh button or press F5.)  

 

 This will be the home page of the site, the one first loaded when a site is accessed. 

 Note: index.html (or index.htm) is the usual name that browsers recognize as the home page, but 
home.html or default.html are also sometimes used. 

c Change the title on the toolbar to a name for a school.  

 

d In the document window type the name of the school, and then press Enter to move to the next line. 

e To save time when making later pages define a style rule for the title as we did in Activity 3.  

 Create this as part of an external style sheet called, for example, school.css. 

                  

refresh 



f Insert the picture school.gif from the Images folder or the assets panel.  

 

g Re-save. 

3. Now that the site is set up and the home page identified, it is time to add some more pages to the site. 

 We could repeat the process above but this time we will do it in a quicker, more efficient way. 

a In the files panel, right click on the site folder and from the context menu choose New File. 

   

 While the new file name is still highlighted rename the file subjects.html, and press Enter. 

b Make files for each of the other pages (curriculum, news, staff, students) from the site map. 

c In turn do the following for each of these files: 

• double click each to open it 

• use the Attach Style Sheet button  at the base of the CSS panel to link it to the external style sheet, 
e.g. school.css 

• add a title and a picture to identify each page 

• format the title using the style rule created in step 2e above. 

   

 These are the simplified pages we will use to build the site. 

d Save each page (File > Save All). 



4. Now we have the site created we will want to be able to navigate between the pages, to another place on the 
same page, or to external sites.  

 We will investigate each of these forms of linking, but to start with we will create simple links between pages. 

a The first thing to do is to link the home page to each of its child pages. 

 On index.html move to just under the picture and type Students, Curriculum and News separated by spaces. 

 

 Note: if the text just entered looks like the title, select it and change its formatting back to None in the 
property inspector. 

b Select the word Students and right click on it. 

 From the context menu choose Make Link. 

             

 In the dialogue that appears link to students.html and press OK. 

c Save the page and test the link in the browser.  

d We can also make links in the properties inspector as we did in Activity 1. 

 Select the word Curriculum and either use the Point to File  or the Browse for File  icon in the 
properties inspector to link to curriculum.html. 

 

 Note: to remove a hyperlink at any time simply delete it from this Link box. 

e Repeat to create a link to the News page. 

f In each of these three pages (Students, Curriculum and News) make a link back to the home page. On the 
Curriculum page make a link to its two child pages. (See the site map at the beginning of this activity.) 

 

 If you wish add other links between pages on the same level. 

g Re-save all pages and test the links work in the browser. 



5. In addition to text we can hyperlink from an image or part of an image (a hotspot). 

a Open the page students.html. 

b We can add a hyperlink from the picture in the same way as we created links on text. 

 Click once on the photograph and then in the properties inspector make a link to the news.html page. 

 Test the link in the browser. 

c A hotspot is a portion of an image that is used to create a link. 

 Return to the students.html page and click once on the image to select it. 

 From the properties inspector click on the Oval Hotspot Tool. 

 

 Click and drag to create an oval around the head of one of the people in the photo. 

 

 A link from this hotspot can now be made to another page, e.g. a page about that person. 

d Experiment with the other hotspot tools (Rectangular and Polygon). 

e To move, resize or delete a hotspot use the Pointer Hotspot Tool.  

 

6. An anchor is a point in a page you can hyperlink to. This can be useful if for example there is a large amount of 
text on a page.  

a Open the curriculum.html page. 

b From the files panel drag the text file subjects.txt to just in front of the hyperlinks under the picture. 

 

 Rather than having to scroll down to each subject we will now create a link from the list of subject names 
under the picture. 

c To start we have to make anchors (target points) at each of the subject headings down the page. 

 Move to just in front of English in the body of the document. 



 From the menu choose Insert > Named Anchor or press Ctrl+Alt+A (PC) / Cmd+Option+A (Mac). 

           

 In the Named Anchor dialogue give the anchor a name. When you press OK an anchor icon will appear next 
to English.  

 This is where the link will jump to. (The anchor is not visible when the page is displayed in the browser.) 

d Create anchors for each of the other subject headings. 

e Now to link from the list under the picture to each of these anchors. 

 Use your mouse to select the first word (English) in the list just under the picture. 

 In the Link box in the Properties inspector type #English. (Care: anchors are case sensitive.) 

    

 When we now click on the link the browser will jump down to the subject heading. 

f Add links to the other anchors. 

g Save the page and test the links in the browser.  

h Create an anchor at the top of the page so that you can allow users to jump back to the top of the page 
after each paragraph. 

 

 Note: you can also create links to an anchor on another page. In the link box simply preface the anchor with 
the page name, e.g. curriculum.html#Maths 

7. We can also link to a page or email address outside of the site. This is known as an external link. 

a Open the home page. 

b Move to the bottom of the page and type EQ site. 

c Select this text and in the Links box enter the URL:  http://education.qld.gov.au/ 

   

d Save the page and test the link in the browser. (It will only work if connected to the internet.) 

e Return to Dreamweaver and add the following on the next line:  

  Contact us: secretary@bunyip.qld.edu.au 

 Select just the email address and in the link box type  mail to: secretary@bunyip.qld.edu.au 

   

 When clicked on in the browser this will open the default mail client with this address selected. 

f Save and close. 



Follow up – Web design 
Things to remember when creating a web site: 

1. The purpose of the site and its potential audience must be clear in your mind when designing it. 

2. Plan the layout of your site before you start. Keep the 3-click rule in mind, i.e. no page should be more than 
three clicks away from the home page. 

3. Keep the site simple and to the point; do not to clutter pages. Make sure text can be read against any 
background color or image. 

4. Ensure pages download as quickly as possible; internet users are impatient: 

• minimize the use of graphics or Flash animations 

• optimize images to reduce download time. 

• use style sheets for formatting, and tables for layout (tables are HTML and download quickly). 

5. Have clear and consistent navigation: 

• links are well organized, easy to understand, and consistent throughout the site 

• important links are positioned prominently at the top or left, so that users do not have to scroll to see them 

• check there are no dead ends or broken links. 

6. Prepare the site for all resolutions: 

• from 640 x 480 (rare), through 800x600, to 1024 x 768 (most common), or higher 

• make sure tables use relative not absolute measurement, i.e. in percentages not pixels 

• use relative (Left/Right) not absolute positioning for images. 

7. Make sure your site is browser compatible: 

• if possible test the site using different browsers (IE, Firefox, Opera, etc.) 

• keep the font range simple, and use common typefaces. 

  



Activity 6 – Publishing 
Once your web site is ready you will want to publish it to the Internet or to an intranet so that others can view it. 

Normally to publish to a remote server over the internet we would use FTP (file transfer protocol). In this activity 
however we will publish the site to a different computer on your network.  

Note: if you cannot publish to a different computer for any reason, you can publish to a folder on your local 
computer. In this case others will not be able to access your site. 

1. Firstly check the site is ready to publish: 

• make a check all pages and page layout are as you want; check spelling 

• ensure all images have been optimized to save download time  

• check the user can navigate to all parts of the site, and back again 

• check all links work; to assist with this you can access the link checker with Site > Check Links Sitewide or 
Ctrl+F8 / Cmd +F8; 

 

 click on the arrow on the left to choose what links to check for 

• check your site is compatible with different browsers (what you see on your screen is not necessarily what 
others get); this can be done in a different tab to the link check above (Ctrl+F8 / Cmd +F8) 

 

2. Once you are sure the site is ready to publish it is necessary to connect to the remote server. This will be on a 
different computer to yours, that you can access, and where a folder has been created for you to publish to. 

a In the files panel click on the Connects to remote host button. 

 

 This will take us to the Site Setup dialogue we encountered when we first set up the site at the beginning of 
Activity 5. 

 

 The Site box has a green tick showing that the site has been named and the local site folder identified.  

 The red asterisk next to Servers indicates that we have not yet identified where the site is to be published 
to. 



b Click on Servers and then in this dialogue click the Add new Server button . 

 

c By default Dreamweaver expects you to publish to a web server using FTP. 

 If you have access to a web server you may do that at his point, but for our purposes we will publish to a 
computer on the local network. (If this is not possible see the note below.) 

 Use the drop down arrow next to Connect using to choose Local/Network. 

 

 In the sub-dialogue that appears name the server and then click on the Browse button next to Server Folder.  

 



 Look in Network, to find the folder to publish the site to. 

   

 This remote folder is also known as the host folder as it hosts your site for you, delivering files as requested. 
(When hosted over the internet this remote folder would be typically labeled as public_html or similar.) 

 When ready accept the other default settings and click Save and Save to exit the dialogues. 

 Dreamweaver will recreate the cache to record the changed status of the site, as it will now be maintained 
in two places. 

 Note: if for any reason you cannot publish to a different computer, follow the steps above but choose a 
folder on your own computer to publish to. This will give a sense of what is involved, but other users will 
not be able to access your site. 

3. We are now ready to upload the files to the server. 

a At present there are no files in the remote host folder. 

 This can be seen by choosing the Remote server option in the files panel.  

                 

b Return to Local view, select the School site in the files panel, and click on the Put File(s) button. 

 The files from your local computer will be uploaded to the server into the folder you specified. This can be 
seen if you now check the remote view in the files panel. 

 To be able to see both the local and remote folders at once use the Expand button at the top right of the 
files panel. 

 

 

 The files on the left are on the remote server, on the right are the files on the local computer you are using. 

 The Collapse button on the right of the toolbar will return to normal view. 



4. Dreamweaver makes it easy to maintain a site once it has been published. 

a Make a change to one or two of the pages and re-save. 

b In expanded view you will see that the date/time stamp of the remote and local files are now different. 

 Click on the Synchronize button.  

    

 Note: one of the options here was to refresh the whole site. This would only be necessary if you had made 
wholesale changes.  

 When you click on the Preview button you will be presented with a list of the file(s) to be uploaded.  

 

 When ready click OK. The changed file(s) will be uploaded. 

5. To view sites published by others, in the browser use File > Open to locate their folder over the network. 
Alternately, if server software has been installed, you will be able to access the other sites using the IP of the 
host computer. 

 Double click on their index.html to view their site. 

Note: in addition to publishing sites you create, Dreamweaver can also be used to maintain sites already in existence. 
To do this you will need to be able to connect to the site and have access authority (usually a password).  

When connected, the entire remote site, or just a single page, can be copied to your local computer. Once there it 
can be edited in Dreamweaver. When ready the improved page(s) can be re-uploaded to the server. 

  



Activity 7 – Come to the table 
Tables are an effective way for presenting data in rows and columns much as in a word processor. They can also be 
used to lay out and position text and graphics on a page.  

(Note: the Layout tables facility as used in earlier versions of Dreamweaver has been discontinued as it led to 
inefficient, poorly ‘coded’ pages.) 

1. To look at how tables can be used we will work with an existing table, originally created in Excel, and then saved 
as a text file.  

a Start a new blank HTML web page. 

b Type the heading Rainfall 2007-11 and format it as a Heading 1. 

 

c From the menu choose File > Import > Tabular Data. 

 In the dialogue that appears browse to the Dreamweaver folder and select  the file Rainfall.txt. 

 Accept the other defaults, except set the top row formatting as Bold. 

  

 When ready press OK. 

 

 This table has 6 rows (across) and 14 columns (down). Together these make up 84 cells or places with data 
or headings in them. 

 The green band across the top of the table is used to display the table and column widths. Values will 
appear in this band whenever you change table or column widths.  

 Sometimes this green band will appear across the bottom of a table. (The green band can be disabled in 
Edit > Preferences if you wish.) 



d While the table is selected information about the table is displayed in the properties inspector.  

 

 Note: to select the table click on any of the row or column dividers, or on an edge of the table. Resizing 
handles will appear to show the table is selected. 

e If you click in a cell, information about that cell is displayed. 

 

 (If necessary click on the expander button at lower right to see this information.) 

 To select an individual cell as a whole, e.g. to format or copy it, Ctrl+click / Cmd+click in the cell. A black box 
will appear around the cell to show it is selected.  

 

f To select a row or column click your mouse at the left edge of the row, or above the top edge of a column. 
The row or column will have a red box around it to show it is selected. 

g Save the page as rainfall.html and view it in the browser. 

 Note: you might like to switch to code or split view and see the HTML behind the table. 

2. Now that we have a table of data we will see how we can vary it. 

a The first thing we will do is make the years in the first column match the month headings. 

 With your mouse click and drag to select the values in this column. As you select the cells you will see a 
black box will appear around each. 

             

 Use the HTML properties inspector to make these values bold. 

 Repeat to make the totals in the last column bold also. 

b Next we will center the rainfall figures in their columns. 

 Use your mouse to select all of the non-bold values. 

 In the HTML properties inspector choose the Center option for the Horz positioning. 

         



 Each of the rainfall values will now be centered in its cell. 

 Note: the default vertical position (Vert) within a cell is centered. 

c To change the contents of a cell click in it once and make the alterations.  

 The rainfall figure for Oct 2007 has been transposed. Change the 45 to 54 and adjust the yearly total. 

d You can vary the overall size of the table by selecting the table (click an edge) and by then dragging on one 
of the table border handles.  

 Try this.  

 As you do this all of the cells will resize proportionally. 

 The table width is displayed in the green band at the top (or bottom) of the table and in the properties 
inspector. 

               

e To alter the column width or row height drag on the cell borders or row/column dividers. 

 

 

 

 

 After resizing a column, the column widths are displayed in the green band above (or below) the table. 

 Note: columns will only resize within the current table width. If there is no room to resize a column within 
this space you will not be able to make it wider. To get around this, hold down Shift while dragging. This will 
push columns to the right, resizing the table at the same time. 

 Shift-drag is also the way to resize a column’s width without affecting the width of columns to its right. 

f Next to the table width at the top is a drop down arrow for the table header menu. You can use this to clear 
(undo) all changes to row or column width. 

 

g We can add rows or columns into the table. 

 Click in the table where you want to make the addition, and then in the insert frame at right click on the 
down arrow next to Common and choose the Layout category.  

               

 Experiment with the various insert options. 



h To merge cells select two adjacent cells and then click on the merge cells button in the properties inspector. 

         

 To split one cell into two or more, or to unmerge cells, use the split cells button . 

 Try this. 

i Save the page, and then view it in the browser (F12). 

3. Now we will set up our own table from scratch. 

a Create a new blank HTML page. 

b From the insert frame at the right choose Table (or from the menu choose Insert > Table). 

                   

c In the dialogue that appears create a 3 x 3 table, with None as the Header. 

 This 3 x 3 table has nine cells or places where text or graphics could be placed. 

 There is a border (line) around each individual cell, and a border around the table as a whole. 

d Type some text into the cells of the table. 

 Use your mouse or the tab key to move from cell to cell. 

e Try resizing the table, columns or rows as we did above. 

 Try also inserting rows or columns and merging cells. 

4. We will now look at more options for table layout. 

a Move to below the table made above and create a new table, but this time choose Both in the Header 
option in the Table dialogue. 

   

 This will format the left column and the top row to appear as headings. Enter some data into the table to 
see the difference. 

 View in the browser. 

 Note: in addition to improving presentation, table headings help visually impaired users who may use a 
screen reader to keep track of table information. 



b Create another table but this time in the Table dialogue set a caption. 

   

 The caption will appear above the table. 

 View in the browser. 

c Select any of the tables you have made and note the detail in the properties inspector. 

 

 Experiment with each of the following. As you try each, re-save the page and then view the table in the 
browser to see the effect. 

• the number of rows and columns can be increased or decreased 

• Align can be used to position the table at the left, center, or right of the page; 

 

 with Left or Right chosen for Align, text will wrap around the table, the same as it wraps around 
graphics 

• a cell padding (CellPad) of 1 means text and graphics will be 1 pixel from the border of the cell (and 
hence 2 pixels from information in the next cell) 

• cell spacing (CellSpace) is how far apart the cells are from each other, i.e. the gap in the border lines; 
try different values for each of these 

• Border is how wide the row and column dividers are; with a Border size of 0 the table lines will not be 
visible when displayed in a browser;  

 

 this can be useful to neatly lay out information without the user seeing how this was achieved 

• the width of the table can be set in pixels, or as a percentage relative to the width of the window it 
appears in;  
try different percentage widths, e.g. a 90% centered table will fill most of the browser, but with a gap 
at each side;  

 

 a table with this setting will fill 90% of the width regardless of how wide the browser window is (except 
for when the window is narrower than the actual width of the cell contents). 



d In the insert frame change the layout category from Standard to Expanded. 

   

 (If necessary click the down arrow next to the label at the top of the insert panel to change to Layout. As an 
alternative you can use View > Table Mode > Expanded Tables Mode.) 

 In expanded mode extra cell padding and spacing is added to make it easier to work on text or individual 
cells. Expanded mode does not change how the table will display in the browser. 

 To return to the standard table display click the [exit] at the top or press Standard in the layout category. 

5. It is now time to see how we can position graphics across a page using a table for display. 

 In a new document create a table of one row with three columns. 

 Insert a picture into each cell, e.g. from the sports’ store images of Activity 4. 

 

 In the properties inspector for the table set Align as Centre, the Width to be 100% and the Border to be 0. 

 Centre each image in its cell. 

 Save the page and view it in a browser. 

 Change the width of the browser window and note how the images move to fit the window. 

 This is a simple example of how to use a table to position images on a page. No matter what sized browser 
window the page is displayed in, the images will be evenly spaced.  

6. Create a table with a complex layout. 

 

 Make up text of your own and insert suitable images. 

 We will explore the use of tables for layout in the next activity. 



Activity 8 – Templates 
A template is a re-useable design for a page. Not only does the use of templates simplify the creation of pages, but it 
gives a site a presentation that is consistent in layout and in usage because all pages have the same basic 
appearance. In addition, a design change only has to be made once in the template to update all of the pages based 
on that design. 

In this activity we will firstly set up a page and then see how to use the page as the basis for a template of a new 
website for Spongebob Squarepants.  

Note: if you wish you can follow the steps below, but set up a template for a website of your own choosing. To do 
this set up a folder for the site with a series of images to use and a style sheet. 

1. Create a new site in the sbsp2 folder (Site > New Site). 

2. The page template we make will have the following basic layout. 

 

 

 

 

 

 

 

 

 

 

 There will be banner across the top to hold a logo and title. Below this will be a content area to display text, with 
a navigation area at left. At right we will have a sidebar, with room for an image in the upper section. Finally 
there will be a footer area for contact and other information. 

 To organize the page in this way we will use a table with no borders. 

a Start a new blank web page. 

b Into this page insert a 4 x 3 table, 800 pixels wide, with border thickness of 0, and no header or caption. 

c Resize the rows and columns and use the merge cells option to lay out the cells to fit our plan above. 

 
 Note: page layout can also be set up in a CSS, but that is beyond what we will be exploring at this time. Page 

layout with CSS is described at the end of this activity. 



d Use the properties inspector to set the background color of the page to a suitable color. 

e We will now save this page as a template. 

 Use the Common tab on the insert panel to access the Templates button. 

   

 Click on the Make Template option, and save it in the sbsp2 site as sbsp_template. 

 (If prompted to update links click Yes. This will ensure links to images are maintained.) 

 The template will appear in a Templates folder in the Files panel, as well as in the Assets panel when you 
click on the Templates icon. (Check you are in Local View.) 

    

 The .dwt extension indicates this is a template. 

3. Now to add the basic content that will appear on every page of our site. (If creating a template for your own 
subject vary the image selections below.) 

a From the files or assets panel drag sbsp logo.gif to the top left of the banner.  

 Since this is a transparent gif the background color can be seen through it. 

 

 Add several of the character gifs alongside this, resizing as necessary. 

b Click in the cell at the left of the table that will act as the navigation area (see next page), and set the 
vertical alignment of the cell to Top. 

 



 Into this navigation area drag the buttons from the files panel into place. 

   

c A template is used to specify the appearance and repeating elements of a web page, it is not used to specify 
text format. To format text we can use a CSS which is a separate document to the template. We can 
however add a CSS to a template so that it is available as part of the template. 

 Use the Attach Style Sheet button at the bottom of the CSS styles panel to link to sbsp.css. 

 

 This style sheet will now be available whenever the template is used. In addition any change in the style 
sheet will also cascade through any pages based on the template. 

d Resave and preview in the browser. (Ignore any warnings about no editable regions; we will set these up 
shortly.) 

4. a Add some content to the bottom panel. (Make this up.) 

 

b Click on the edge of the table to select it and set the table width to 100%. 

 

 This means the table will expand to fit the browser window it is displayed in. 

c Save and preview in the browser. 

 Try varying the width of the browser window to see the table expand or contract to fit. 



5. Some areas in a template will remain the same for every page, but we will want some areas that can have 
content or graphics added to them. The parts that will be changed are called editable regions. 

a Click once in the central cell. 

 When we use the template to create a page this cell will hold a picture or text. 

b From the insert panel click on the down arrow on the Templates button and choose the Editable Region 
option.  

 

 When prompted call this region main. 

    

 The name of the region (main) and some default text (main again) will appear.  

 Use the property inspector to locate this at the top of the cell. 

    

 The default text can be replaced by text or a graphic when the template is used to create a page. 

c Repeat for the cell at lower right calling it sidebar. 

 

d Re-save. 

e The upper right cell is to be used to display a graphic image. 

 Make this an editable region called graphic and set the position for the graphic as top center. 

      

f Re-save. 



6. We will now see the template in action. 

a From the menu choose File > New with the Page from Template option. 

 

 Choose the template made and click on the Create button.  

 A new untitled page based on the template will appear. 

 Note: leave the Update page when template changes option ticked. (What effect will this have?) 

b Make some changes to this page, e.g. add a picture to the main panel in the middle. 

 Save the page as index.html. This will be the home page for the site. 

c Use the template to make at least two other pages, e.g. characters.html and location.html. 

 Add some text and images to each of these pages and save them. 

7. Once we have a series of pages we will want to be able to navigate between them. 

a Move back to the template and create a link from the Home button to index.html. 

 

b Make links to the other pages created above. 

c Re-save the template and any open pages (File > Save All). 

 Even though we have only changed the template each of the pages we have made will also now have the 
links on them. Test this is the browser. 

d Make another change to the template (e.g. to the background color, the banner, 
or the footer), and see how the changes are transmitted to all pages based on the 
template. 

 Note: if the changes in the template do not automatically update in pages made 
from it, use Modify > Templates > Update Pages.  

 Alternatively you can update a single page. In the assets panel choose the 
templates category and click on the Apply button. 

 This will update the template changes to just the selected page. 



Follow up – page layout using CSS 
The content on a web page can be organized and laid out using a Cascading Style Sheet rather than a table. As with 
using CSS for styles, this method creates a more flexible and efficient form that is easy to update.  

The basic building block of CSS layout is the HTML <div> tag that acts as a container for text, images, and other page 
elements. Unlike table cells, which are restricted to just the rows and columns of a table, div tags can appear 
anywhere on a web page. 

Dreamweaver comes with pre-designed CSS layouts that you can use.  

 

When created such a layout page will come with the specified columns, headers, footers, and so on, with sample text 
in them ready to attach an external style sheet. 

Alternately you can create CSS layouts of your own by placing div tags to specify logical divisions within the content 
of a page. These can then be used to center blocks of text, create columns, specify different areas of color, and so on.  

Div tags can be positioned absolutely by specifying x and y coordinates, or relatively by specifying their distance from 
other page elements. See Help for assistance in doing this.  

Note: one limitation of using absolutely positioned, or AP, elements is placement may not adjust well relative to the 
size of the browser window. 

To see div tags used for placement, visit a well-designed site such as Slashdot. On the site view the source code for 
the page (Firefox: View > Page Source; IE: View > Source) and scroll down to find the <div> tags in action. 

  

http://slashdot.org/


Dreamweaver CS6 Setup 
Prior to use by students these activities require Dreamweaver to be set up with the sites for sbsp and Sports Store 
available in the ‘Designer’ workspace. In addition students will require access to the folders for SBSP2 and School, as 
well as a shared network folder.  

To do this follow the steps below.  

1. Create a folder that will be accessible to students doing these activities.  

 Copy the provided Dreamweaver files into this folder. 

These files can be obtained from here. 

2. By default Dreamweaver CS6 has the Business Catalyst panel displayed in the 
panels group at right. This is purely promotional and I suggest it be closed to avoid distraction. 

To do this, in Dreamweaver, click on the menu button at right of panel title bar and choose Close. 

                

I also suggest you expand the Files/Assets panel group if it is collapsed. To do this click once on the Files tab at 
lower right, or press the F8 function key on the keyboard. 

 

This will make it easier for students to find the required files and assets. 

Dreamweaver will retain this workspace layout, even after being closed, until the Reset ‘Designer’ option is 
chosen on the Designer button. 

3. There are two sample sites to set up. Prepare the sbsp site first by following these steps. 

a Either: 

• from the Welcome screen under Create New choose Dreamweaver Site, or  

• from the menu choose Site > New Site. 

          

http://www.edit.net.au/files/Adobe%20CS6/DreamweaverCS6.zip


b In the Site Definition dialogue that appears, in Advanced Settings, name the site sbsp and set the local site 
folder to the SBSP folder created in step 1 above. 

        

 When ready click on Save and the sbsp site will appear in the Files panel at right. 

 Note: the local site folder is the working directory Dreamweaver uses to store all files used in a site. When 
the site is ready to publish these files are then transferred to a remote folder on another computer on the 
network, or to a web server. 

4. Repeat these steps to set up the Sports Store site. 

You can use the drop down arrow in the files panel to access either site. 

 

5. As a final check ensure all who work on the activities have the following setup on their computer before 
beginning: 

• the interface is in the Designer workspace with the files panel in view at right 

• the sbsp site is ready to use and is displayed in the files panel  

        

• the Sports Store site is also available to use 

• the SBSP2 folder is accessible to students 

• the School folder is accessible to students 

• students have access to a remote folder (or web server) that they can publish their site to in Activity 6. (A 
remote folder is a folder on a different computer, accessed over a network connection.) 

If this is not possible because of network restrictions students will still be able to publish their site to a 
folder on their local computer, but others will not be able to access it. 

 

Good luck, and enjoy Dreamweaver CS6! 


