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Year Jan [Feb Mar Apr May [Jun Jul [Aug [Sep |Oct[Nov Dec Total
2007[ 87 [187/115 60 | 22 [80]25] 0 [70 [45 [125] 96 [912.0
48
56

2008120 150|110 52 |7513| 17 |58 | 62|120/|115940.0
1200985 | 96 | 84 492128 |66 |73 | 94 112 827.0
12010(102198) 102 | 35 670 |25 |45 70 |112 83 899.0
2011| 78 177| 99 |55 6420 | 5 |65 |50 |109 | 87 [849.0
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Each of the rainfall values will now be centered in its cell.

Note: the default vertical position (Vert) within a cell is centered.

To change the contents of a cell click in it once and make the alterations.

The rainfall figure for Oct 2007 has been transposed. Change the 45 to 54 and adjust the yearly total.

You can vary the overall size of the table by selecting the table (click an edge) and by then dragging on one
of the table border handles. L13[yau0 | |

Try this. 112/827.0
As you do this all of the cells will resize proportionally. e

The table width is displayed in the green band at the top (or bottom) of the table and in the properties
inspector.
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After resizing a column, the column widths are displayed in the green band above (or below) the table.

Note: columns will only resize within the current table width. If there is no room to resize a column within
this space you will not be able to make it wider. To get around this, hold down Shift while dragging. This will
push columns to the right, resizing the table at the same time.

Shift-drag is also the way to resize a column’s width without affecting the width of columns to its right.
Next to the table width at the top is a drop down arrow for the table header menu. You can use this to clear
(undo) all changes to row or column width.
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We can add rows or columns into the table.

Click in the table where you want to make the addition, and then in the insert frame at right click on the
down arrow next to Common and choose the Layout category.

wsesr |
© Common

Layout [
Forms

Experiment with the various insert options.
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h  To merge cells select two adjacent cells and then click on the merge cells button in the properties inspector.

Year |Jan Fe Year Jan [Fet

2007[87 |18 87 18"
Ql 20072008

2008 120 |15 120 15(

200085 |96 2009 85 |96

To split one cell into two or more, or to unmerge cells, use the split cells button E
Try this.

i Save the page, and then view it in the browser (F12).

3. Now we will set up our own table from scratch.

a  Create a new blank HTML page.

b From the insert frame at the right choose Table (or from the menu choose Insert > Table).
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Summary:
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¢ Inthe dialogue that appears create a 3 x 3 table, with None as the Header.

This 3 x 3 table has nine cells or places where text or graphics could be placed.

There is a border (line) around each individual cell, and a border around the table as a whole.
d  Type some text into the cells of the table. _— "

Use your mouse or the tab key to move from cell to cell. Mne ‘in(
e Tryresizing the table, columns or rows as we did above. ot et

Try also inserting rows or columns and merging cells.

4.  We will now look at more options for table layout.

a  Move to below the table made above and create a new table, but this time choose Both in the Header
option in the Table dialogue.
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one | two | three

four [five |six

seven [eight |nine

This will format the left column and the top row to appear as headings. Enter some data into the table to
see the difference.

View in the browser.

Note: in addition to improving presentation, table headings help visually impaired users who may use a
screen reader to keep track of table information.
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Create another table but this time in the Table dialogue set a caption.

Gaming scores

Caption: Gaming scores
Summarv:

The caption will appear above the table.
View in the browser.
Select any of the tables you have made and note the detail in the properties inspector.

FrorerTEs
EE Rovs |3 w 200 Celpad Ain [Default_v] Cless None  ~
v Cos 3 CellSpace Border 1
L L RS

=
Experiment with each of the following. As you try each, re-save the page and then view the table in the
browser to see the effect.

e the number of rows and columns can be increased or decreased
e Align can be used to position the table at the left, center, or right of the page;

Aon [efait 1]

Default
Jorder | o
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with Left or Right chosen for Align, text will wrap around the table, the same as it wraps around
graphics

a cell padding (CellPad) of 1 means text and graphics will be 1 pixel from the border of the cell (and
hence 2 pixels from information in the next cell)

cell spacing (CellSpace) is how far apart the cells are from each other, i.e. the gap in the border lines;
try different values for each of these

Border is how wide the row and column dividers are; with a Border size of 0 the table lines will not be
visible when displayed in a browser;

one  two three

four  five six

seven eight nine

this can be useful to neatly lay out information without the user seeing how this was achieved

the width of the table can be set in pixels, or as a percentage relative to the width of the window it
appears in;

try different percentage widths, e.g. a 90% centered table will fill most of the browser, but with a gap
at each side;

Rows 3 W 90 CelPad Allgn | Center v/

Cols 3 pixels CelSpace Border 1

a table with this setting will fill 90% of the width regardless of how wide the browser window is (except
for when the window is narrower than the actual width of the cell contents).
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d  Inthe insert frame change the layout category from Standard to Expanded.

wsext [ Expanded Tables mode [exit]
- oo B e P B T P,
Standard | Expapded |

Insert Div

LR three

(If necessary click the down arrow next to the label at the top of the insert panel to change to Layout. As an
alternative you can use View > Table Mode > Expanded Tables Mode.)

In expanded mode extra cell padding and spacing is added to make it easier to work on text or individual
cells. Expanded mode does not change how the table will display in the browser.

To return to the standard table display click the [exit] at the top or press Standard in the layout category.

It is now time to see how we can position graphics across a page using a table for display.
In a new document create a table of one row with three columns.

Insert a picture into each cell, e.g. from the sports’ store images of Activity 4.
e P P P P B s

In the properties inspector for the table set Align as Centre, the Width to be 100% and the Border to be 0.




image14.tmp
Centre each image in its cell.

Save the page and view it in a browser.

Change the width of the browser window and note how the images move to fit the window.

This is a simple example of how to use a table to position images on a page. No matter what sized browser
window the page is displayed in, the images will be evenly spaced.

Create a table with a complex layout.

Slammer $78.95 -
Made from the finest willow this bat is

imported from England. Guarantead for 5

years on normal usage

Sizes: 6,8, 10,12 ®
Grippers $45.50 a pair

Mede in India fronm qualily lealhier Liese
gloves will give your wicket keeping the
dge you need to capture the finest edges

Sizes: 15,18.24

Protecta $9875

For the ultimate in protection this helmet will
ensure your on field safety. With quality
d
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Make up text of your own and insert suitable images.
We will explore the use of tables for layout in the next activity.
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Activity 7 — Come to the table

Tables are an effective way for presenting data in rows and columns much as in a word processor. They can also be
used to lay out and position text and graphics on a page.

(Note: the Layout tables facility as used in earlier versions of Dreamweaver has been discontinued as it led to
inefficient, poorly ‘coded’ pages.)

1. Tolook at how tables can be used we will work with an existing table, originally created in Excel, and then saved
as a text file.
a  Startanew blank HTML web page.

b Type the heading Rainfall 2007-11 and format it as a Heading 1.

Code | soit [Deson | | weCode | p% [ | e
D Sl @d ® on

OV PP O WP VR PP

Rainfall 2007-11

¢ From the menu choose File > Import > Tabular Data.

In the dialogue that appears browse to the Dreamweaver folder and select the file Rainfall.txt.
Accept the other defaults, except set the top row formatting as Bold.
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When ready press OK.

Rainfall 2007-11_

e e

Year|Jan [Feb Mar Apr May Jun Jul|[Aug Sep Oct Nov Dec Total
2007[87 [187]115 [60 [22 |80 250 |70 [45 [125[96 [912.0
2008[120(150 (110 48 [52 |75 [13 17 [s8 [62 [120 [115][040.0
2009(85 [96 84 |56 |63 |49 21|28 |66 [13 |94 |112 [s270)
2010[102(198(102 35 [60 67 o [25 [45 [70 [112][s3 [899.0

2011|78 [17799 |55 |40 61.20 5 |65 |50 [109 |87 849,0.

This table has 6 rows (across) and 14 columns (down). Together these make up 84 cells or places with data
or headings in them.

The green band across the top of the table is used to display the table and column widths. Values will
appear in this band whenever you change table or column widths.

Sometimes this green band will appear across the bottom of a table. (The green band can be disabled in
Edit > Preferences if you wish.)
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d

While the table is selected information about the table is displayed in the properties inspector.

g
::_EI Table Rows |6 w CelPad Algn [Defat v Class Nore

M Cols | 14 Celspace. Border | 1

Note: to select the table click on any of the row or column dividers, or on an edge of the table. Resizing
handles will appear to show the table is selected.

If you click in a cell, information about that cell is displayed.

Fomat [lone  v|  Cass tene - B2 ®
D None - Link %

TE) ca ke W] tews] 5[] Page roperis...
036 e o n ) Sa.

(If necessary click on the expander button at lower right to see this information.)

To select an individual cell as a whole, e.g. to format or copy it, Ctrl+click / Cmd+click in the cell. A black box
will appear around the cell to show it is selected.
]
17[115] 60
wl1inae
To select a row or column click your mouse at the left edge of the row, or above the top edge of a column.
The row or column will have a red box around it to show it is selected.

Save the page as rainfall.html and view it in the browser.
Note: you might like to switch to code or split view and see the HTML behind the table.
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Now that we have a table of data we will see how we can vary it.

The first thing we will do is make the years in the first column match the month headings.

With your mouse click and drag to select the values in this column. As you select the cells you will see a
black box will appear around each.

Year |Jan Feb Mar Ap Year Jan Feb Mar Apr|May [Jun Jul Aug|Sep |Oct Nov Dec Total
2007]87 [187 115 |60 200787 [187[115 [60 [22 [s0 250 [70 [45 [125[96 [912.0
2008](120 (150|110 |48 2008[120(150 110 [48 [52 [75 [13 17 [58 [62 [120 [115 [940.0
2009]85 |96 84 |56 2009(85 (96 [84 56 [63 [49 2128 66 [73 [o4 [112827.0
[2010][102 198 102 35 2010[102[198[102 [35 [60 67 [0 [25 [45 [70 [[112 23 [899.0
2011]78 [177)99 |55 201178 [177[09 [55 [40 64 [20 5 [65 [50 [[109 [87 [849.0

Use the HTML properties inspector to make these values bold.

Repeat to make the totals in the last column bold also.

Next we will center the rainfall figures in their columns.
Use your mouse to select all of the non-bold values.

In the HTML properties inspector choose the Center option for the Horz positioning.




