Activity 5
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f  Insert the picture school.gif from the Images folder or the assets panel.
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g Re-save.

3. Now that the site is set up and the home page identified, it is time to add some more pages to the site.
We could repeat the process above but this time we will do it in a quicker, more efficient way.
a In the files panel, right click on the site folder and from the context menu choose New File.
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While the new file name is still highlighted rename the file subjects.html, and press Enter.
Make files for each of the other pages (curriculum, news, staff, students) from the site map.
In turn do the following for each of these files:

o double click each to open it

e use the Attach Style Sheet button &8 at the base of the CSS panel to link it to the external style sheet,
e.g. school.css
add a title and a picture to identify each page
format the title using the style rule created in step 2e above.
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Curriculum

These are the simplified pages we will use to build the site.
d  Save each page (File > Save All).
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Now we have the site created we will want to be able to navigate between the pages, to another place on the
same page, or to external sites.

We will investigate each of these forms of linking, but to start with we will create simple links between pages.
a  The first thing to do is to link the home page to each of its child pages.
On index.html move to just under the picture and type Students, Curriculum and News separated by spaces.

Students Curriculum News

Note: if the text just entered looks like the title, select it and change its formatting back to None in the
property inspector.

b Select the word Students and right click on it.
From the context menu choose Make Link.

wrap 1ag...
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"Make Link @ students.html m 3
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Remove Link

In the dialogue that appears link to students.htm/ and press OK.
¢ Save the page and test the link in the browser.
We can also make links in the properties inspector as we did in Activity 1.
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Select the word Curriculum and either use the Point to File & or the Browse for File D icon in the
properties inspector to link to curriculum.html.
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Note: to remove a hyperlink at any time simply delete it from this Link box.
e  Repeat to create a link to the News page.

f  Ineach of these three pages (Students, Curriculum and News) make a link back to the home page. On the
Curriculum page make a link to its two child pages. (See the site map at the beginning of this activity.)

Home Staff Students

If you wish add other links between pages on the same level.

g  Re-save all pages and test the links work in the browser.
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5. In addition to text we can hyperlink from an image or part of an image (a hotspot).

a  Open the page students.html.

b We can add a hyperlink from the picture in the same way as we created links on text.
Click once on the photograph and then in the properties inspector make a link to the news.htm/ page.
Test the link in the browser.

¢ Ahotspot is a portion of an image that is used to create a link.
Return to the students.html page and click once on the image to select it.
From the properties inspector click on the Oval Hotspot Tool.

Click and drag to create an oval around the head of one of the people in the photo.
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A link from this hotspot can now be made to another page, e.g. a page about that person.
d  Experiment with the other hotspot tools (Rectangular and Polygon).
e  Tomove, resize or delete a hotspot use the Pointer Hotspot Tool.
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6. Ananchor is a point in a page you can hyperlink to. This can be useful if for example there is a large amount of
text on a page.

a  Open the curriculum.html page.
b From the files panel drag the text file subjects.txt to just in front of the hyperlinks under the picture.

Engish Maths Science History Geography Phys Ed
English

Lorem ipsum dolor sit amet, consectetur adipisicing elit, sed do eiusm
enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut
reorehendent in wohiotate welit rsse cillum dolore en fusiat milla paniat

Rather than having to scroll down to each subject we will now create a link from the list of subject names
under the picture.

¢ To start we have to make anchors (target points) at each of the subject headings down the page.
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From the menu choose Insert > Named Anchor or press Ctrl+Alt+A (PC) / Cmd+Option+A (Mac).

Named Anchor =X English
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Anchor name: English &S aliqua. Ut enim ad minim veniam, qu
aute irure dolor in reprehenderit in v.

In the Named Anchor dialogue give the anchor a name. When you press OK an anchor icon will appear next
to English.

This is where the link will jump to. (The anchor is not visible when the page is displayed in the browser.)
Create anchors for each of the other subject headings.

Now to link from the list under the picture to each of these anchors.

Use your mouse to select the first word (English) in the list just under the picture.

In the Link box in the Properties inspector type #English. (Care: anchors are case sensitive.)

Link | #English English Maths Science Histc

When we now click on the link the browser will jump down to the subject heading.
Add links to the other anchors.
Save the page and test the links in the browser.

Create an anchor at the top of the page so that you can allow users to jump back to the top of the page
after each paragraph.

Duis aute irure dolor in

cupidatat non proident,

Top.
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Note: you can also create links to an anchor on another page. In the link box simply preface the anchor with
the page name, e.g. curriculum.html#Maths
We can also link to a page or email address outside of the site. This is known as an external link.
a  Open the home page.
b Move to the bottom of the page and type EQ site.
¢ Select this text and in the Links box enter the URL: http://education.qld.gov.au/

EQ site Link [ http://education.qld. gov.au

d  Save the page and test the link in the browser. (It will only work if connected to the internet.)
e Return to Dreamweaver and add the following on the next line:
Contact us: secretary@bunyip.qld.edu.au
Select just the email address and in the link box type mail to: secretary@bunyip.qld.edu.au
EQ site

Link | mail to: secretary@bunyip.qld.edu.au
I— yChaye.q Contact us: secretary@bunyip gld edu.au

When clicked on in the browser this will open the default mail client with this address selected.
f  Save and close.
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Follow up — Web design
Things to remember when creating a web site:

1
2.

The purpose of the site and its potential audience must be clear in your mind when designing it.

Plan the layout of your site before you start. Keep the 3-click rule in mind, i.e. no page should be more than
three clicks away from the home page.

Keep the site simple and to the point; do not to clutter pages. Make sure text can be read against any
background color or image.

Ensure pages download as quickly as possible; internet users are impatient:

e minimize the use of graphics or Flash animations

e optimize images to reduce download time.

e use style sheets for formatting, and tables for layout (tables are HTML and download quickly).
Have clear and consistent navigation:

e links are well organized, easy to understand, and consistent throughout the site

e important links are positioned prominently at the top or left, so that users do not have to scroll to see them
*  check there are no dead ends or broken links.

Prepare the site for all resolutions:

e from 640 x 480 (rare), through 800x600, to 1024 x 768 (most common), or higher

e make sure tables use relative not absolute measurement, i.e. in percentages not pixels

e use relative (Left/Right) not absolute positioning for images.

Make sure your site is browser compatible:

e if possible test the site using different browsers (IE, Firefox, Opera, etc.)
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e keep the font range simple, and use common typefaces.
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Activity 5 — Navigation

Now that we have seen how to develop web pages it is time to see how to put them together in a web site and find

out how to move between them in a process called navigation. In this activity we will develop a simple web site for a
school.

In building a site it is important to have a clear idea how the different pages will link together. The site plan we will
use looks like this:

This simplistic site has just three levels and six pages, and is used only to demonstrate the processes involved. Once

the site framework is set up however, it could easily be extended by adding more pages.

A page that has other pages at a lower level is called a parent page, the ones at a lower level are the child pages. In
the site above Curriculum is parent to the child pages Staff and Subjects.

Dreamweaver can manage as many web sites as you wish, but each site must have its own name and have its own
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folder on your local computer to store files. A School folder with an Images subfolder should have already been
created for this in the Dreamweaver folder (see setup).

1. Firstly we will define the site.
a Close any open pages and then from the menu choose Site > New Site ...
(You could also choose Dreamweaver Site under Create New in the Welcome screen.)

b In Advanced Settings name the site School and use the browse button ] to set the Local Site Folder.

A Dreamweaver site is a collection of all of the files and assets you use in your
website. A Dreamweaver site usually has two parts: a local folder on your
Version Control ] computer where you store and work on files, and a remote folder on a server
> Advanced Settings | where you post the same files to the web.

| servess

Here you'll select the local folder and a name for your Dreamweaver site.

Site Name: [ School ]

Local Site Folder: [ C:\DreamiWeaver CS5 fies\School\ &

¢ When ready click on Save and Dreamweaver will set up the site.
This can be seen in the Files panel.

Note: to return to the above dialogue to make any changes, from the menu
choose Site > Manage Sites, and then select Edit. Alternately you can just
double click on School in the files panel.
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2. Once the site is defined create the home page. A home page is the first page visitors to a site see, and is the root
of the tree structure of the site.

a  From the menu use File > New to create a blank HTML page as we did in Activity 3.

Page Type: Layout:
= HML <none>
D Bk Pae S HM template 4 column fxed, centered
) Library item 1 column fixed, centered, header and foot
P8 1t Taniie [ veiT Enbn mane 1 column iuid. centered

b Save this page to the School folder calling it index.

Dreamweaver will automatically add an .htm/ extension onto this file and it should appear in the files panel.
(If it does not click the Refresh button or press F5.)
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This will be the home page of the site, the one first loaded when a site is accessed.

Note: index.html (or index.htm) is the usual name that browsers recognize as the home page, but
home.html or default.html are also sometimes used.

¢ Change the title on the toolbar to a name for a school.




image4.tmp
M—mﬂm
| Code | spit [Deson | tve | GG @ 0 b FE @, O T

h AeZ@s v o® o
Bunyip Primary School
|

d  Inthe document window type the name of the school, and then press Enter to move to the next line.
To save time when making later pages define a style rule for the title as we did in Activity 3.

e .
Create this as part of an external style sheet called, for example, school.css.
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