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Choose Text only and click on OK.

Special offer The first 30 custommersinto the store this weekend will eceive a voucher entting them o
am extra 15% offthe price of any it i store.In ddiion any of our spor’s club members will receive
their usual $% off. Be carly and take advantage of these fantastc offrs. See you on Saturday!

The text without formatting has been placed in our web page.
d  Re-save the page.
Note: the three methods of adding text to a page just described are direct typing, dragging a txt file onto
the page, or a copy and paste from a different application. When preparing your own web pages you can
choose the method most suitable for your task.
3. We will now spread the text out on the page with paragraph and line breaks.
a  Clickjustin front of the The after Special offer and press Enter to put it on a line by itself.

Next move to the bottom paragraph and at the beginning of the second sentence (In addtion...) press
Enter.

These two actions insert paragraph breaks in the text.
Special offer

“The first 30 customers into the store this week
price of any item in store.
T In addition any of our sport’s club members w
these fantastic offers. See you on Saturday!
As you can see a line of space is automatically added between paragraphs.
b I you do not want space between paragraphs it is necessary to insert a line break.

Move to the beginning of the third sentence (8e early....), but this time hold down Shift as you press Enter.
‘Special offer

‘The frst 30 customers into the store this week
price of any item in store.

In addition any of our sport’s club members w
=== Be carly and take advantage of these fantastic

The sentence moves to a new line, but without the in-between space.
(1f you use the Code or Split button to check the HTML you will see the different tags used for these.)
¢ Finally add a full paragraph break between the last two sentences.
At this point re-save the page and view it in the browser (F12).




image6.tmp
‘This page is now ready for us to experiment with. Over the next few exercises we will return to the page in
this state.

Now that we have some text to work with we will format it. We can do this either by changing the HTML or by
using a style sheet. We willstart by seeing how the properties inspector can manipulate HTML to format text.
a  UsefFile > Save As to save the file as sports2.html.
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‘We will make our HTML changes to this second version of the page. In this way we can still be able to come
back to the original version (sports.html) later.
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b Check the HTML properties inspector is selected.
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When this page was created Dreamweaver automatically set up the HTML to display it.
To see this ci
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On the left HTML will be displayed, at the right the text we have entered.

or you can display one on top of the other.
To toggle between the two views click on View > Split Vertically.)

©  Clickanywhere in the title (Sportz World) and then in the properties inspector use the Format option to
select Heading 1.
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Sportz World

Sale now on.

Gym equipment specials:
The title has now been formatted in a heading 1 style as we saw in the last activity.
Looking in the code window we can see the HTML paragraph tags <p> have been replaced by heading1 <ht>

tags.
<body> <body>
<p>Sportz World</p> <ni>sportz World</hl>

<p>sale now on.</p> <p>sale now on.</p>
Use the properties inspector to convert Sale now on and Special offer to heading 2 and Gym equipment
specials and Cricket specials to heading 3.

Sale now on.

Gym equipment specials:
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Now to add some bullets.
Select the five paragraphs under the Gym equipment specials heading.

In the properties inspector click on the Unordered List icon = .

Gylll eq“ipmen' !ped'l“ <h3>Gym equipment specials:</h3>
« cxrcisebikes - Fom §125 C AW PN
- rowng mackines ~Fom §195  SUTIRICIALI BRSO
* treadmills - from §175 <li>weights all sizes - Seall</Li>
e EEmrRIim.
+ work benches — from §95 hArrickar amemialecc/nas

Tags have been added so that the text is formatted as an unordered list <ul>, with each paragraph a list
item <ii>.

An unordered list is more commonly described as bullets.
Note: an ordered st <ol> is where the lines are numbered.

Add bullets to the five paragraphs under Cricket specials.

Lines are good for organizing information or visually separating objects.
Click just in front of the Gym equipment specials heading.

From the insert panel at the right click on Horizontal Rule.

"& o Sale now on.

u Hypek
© Enitnk
& romed e Gym equipment specials:
& rormatiue g,
EE™ + exercise bikes — from $125
(You could of course have just added an <hr/> tag in the HTML)
‘Add another line just above the Special offer heading.

Click on either of the lines and note the changes you can make to them in the properties inspector.
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h At this stage click on the Design button to return to design view alone.
Re-save the page, view it in the browser (F12), and then close it. This finishes our look at HTML formatting.
A style sheet is a way of saving formatting information such as fonts, color, alignment, and so on. The style sheet
can be stored with the HTML code or can be a separate file. We will now see how to use a style sheet to format
our sports page.
(Further information about style sheets is included in the Follow up at the end of this activity.)
2 The changes we make in this step will be to our sports page as it was at the end of step 2 above.
Move to or re-open our original sports.htm.
Use File > Save As to save this ile, this time as sports3.html.
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We will now create a reusable style setting in this third version of our sports store site.
In the properties inspector switch to the CSS properties inspector.

<> HML TargetedRule <

@

Select the title (Sportz World), and while Targeted Rule says <New CSS Rule> click on the Edit Rule button.
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You will be prompted to create a new CSS Rule.
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Name the rule sp_title, accept the other defaults, and press OK.
In the dialogue that appears choose a font, size, weight, and color for the title.

Sportz World

Sale now on.

Gy eauioment specials:

‘When ready click OK. The rule will be applied to the text you had selected (here the title).
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We have created a style rule called .sp_title that has the font, size, weight, and color chosen. (Note that
Dreamweaver has added a full stop at the beginning of the style name.)

This style rule can now be used in other parts of the document.

Click on the text under the title (Sale now on.) and use the drop down arrow next to Targeted Rule to
choose this style.

R Sportz World
(B [ s e

Apply Class
<Remove Gas>

Sale now on.

Gum eaminment snecials

The title style will be applied to this text as well.
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Note: once you have used a style setting you can reuse it anywhere in this document. Using styles like this
will give consistency to the appearance of web pages you create. For example all ttles will be identical.

If you look in the HTML (Code or Split button) you will see the definition of the style.

Lcade 5ok |4 Oesgn_zluvevew )

)

Dreamweaver inserts a style definition like this near the top of the HTML code.
Click on either of the two title lines and change the color or font in the properties inspector.

Both examples of the style will change.

Any variation in the style rule will change all applications of the style in the document. In this way you only
have to make the one change and each occurrence of the rule will ater and be consistent with all of the
others.

Note: for more detailed changes to the style rule click on the Edit Rule button inthe
properties inspector again.

Re-save.

now make three more style rules, but this time we will make them in the CSS panel at right.

Click on text that is not styled s a title and, if necessary, expand the CSS Styles panel by double clicking on
its title bar.
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The CSS panel can also be displayed using Window > CSS Styles or Shift+F11.
Click on the New CSS Rule button 1 at the bottom of this panel.

Name the style rule sp_head1.

Choose a font, size, color, and 50 on tht
When ready press OK.

different to the title.
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©  Use this sp_head1 rule in the properties inspector to format the Sale now on and Special offer headings.
Make a rule for sp_head2 and use this for the other subheadings.
o finish we will make a style rule for the bullet text.
Use the New CSS Rule button to set a font, color and size for the text, calling it sp_bullet.

Rather than set bullet type and indent in the style rule (Block and List categories) it is easier to make the
bulleted list from the menu with Format > List > Unordered List.

Apply the rule to the appropriate paragraphs.

Note: in the CSS properties inspector there is now a List Item button next to Page Properties where you can
set options for the list.

f Re-save and view the page in the browser (F12).

Note: the style rules we have created are listed in the CSS Styles panel under the All tab. These styles can
the HTML properties panel as well as the CSS properties panel. If you switch back to the

sp_heads
_heada

sp_title

‘The use of styles as shown above is limited to just this one web page. If we create a new page we will have to
recreate the styles again one by one. This is inefficient and wastes time.

‘The way around this s to use an external style sheet that can be used across multiple pages, and even multiple
web sites.

We can either make our own external style sheet, or use a pre-existing one. In step Sb above we accepted the.
default of letting Dreamweaver define the style rule for just that page.

Rule Defintion:
Choose where your ke vl be defed.

(s document o)
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We will now create an external style sheet that can be used more widely.
2 Move to or re-open sports.html. Use File > Save As to save it as sportsd. htm.

This is our original sports page with no HTML or style rules.
b Define a style rule for the title, but this time choose the New Style Sheet File option.

Rule Defton:
Choose where your rle i b defned.

o r—
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When you press OK you will be presented with a dialogue requesting a name and location for the style
sheet. By default this wil be in the folder for the Sports Store site and have the extension .css.

Accept these defaults, name the file sport.css and press Save.
‘The style sheet, which for now has just one rule, is stored in sport.css. This can be seen in the files panel.
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¢ Adda second style rule for the first heading (sp_head) as we did in step 6 above, but this time add it to the
sport.css style sheet we have just created.

d  Add subheadings (sp_head2), bullets (sp_bullet) and even paragraph (sp_para) rules to the style sheet. Add
each rule to sport.css.

Hint: you can use the Edit button in the properties inspector or Format from the menu for extra settings.
e Resave, view in the browser, and then close sportsd.html.

8. Tofinish we will see how to use styles we have made in one document to make an external style sheet and then
attach it to another web page.

2 Re-open or access both sports. html, our original sports page with no formatting, and sport3. htmi, the page
with internal style rules we made in steps 5 and 6 above.
‘We will export the style rules from sport3.html to an external style sheet and then attach them to
sports.htm.

b In sport3.html open the All tab in the CSS Styles panel at right. Under <style> you
the rules made for this document.

be able to see all of

Use Ctrivclick (PC) or Cmdsclick (Mac) to select each of the rules.
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Right click in the selection, and from the context menu choose Move CSS Rules.
In the dialogue that appears choose A new style sheet.

[T -
Ste - Sports store.. m

5B mages
ERCE—
i oo Ly 4
= sotshml 2
Click OK and save the style sheet as sp_style.css in the Sports Store folder.
We have now taken the rules we made for the sports’store in steps 5 and 6 and created an external style
sheet from them, L. a style sheet that is independent of the page.

‘We will now import this style sheet into our original unformatted sports.htm/ page.
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Move to sports. html and from the bottom of the CSS Styles panel click on the Attach Style Sheet button 8

Use the Browse button to find sp_style.css in the Sports Store folder and click OK.
All of the styles we created in steps 5 and 6 above are now available.
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These rules can be used to format the text in this page.
Move back to sports3. html and use the Edit button on the property inspector to change the color of the
sp_title rule.

‘When you go to sports. html you will see the title has changed here also.

Changing the title rule (or any other rule) in the style sheet will cause changes to all instances of the rul
any other document that uses it. These changes are said to cascade down through the other documents.
(CSS stands for cascading style sheets.)

We can remove this style sheet and attach another if we

In the CSS Styles panel, click on the style sheet to select it and then click on the unlink button.

i 5 Steshest
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Now click on the link button and this time attach the sport.css we made in step 7 above.
In this way we can attach any style sheet we wish to a page.
Resave sports3.html. We will continue on with this page in the next activity.

Note: Dreamweaver also comes with some basic style sheets that you can attach when you create a new
page. To do this in the new document dialogue choose Page from sample and view the CSS style sheets
available.
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Follow up

Ccss
A cascading style sheet (CSS) is a preset way of presenting layout, color and fonts, that can be saved separately from

a web page. Styles can be used for headings, ordinary paragraphs, bullets, images, backgrounds, positioning items on
a page, and so on.
The fundamental concept behind CSS is that the presentation of a page or site is kept separate from its content.

style
sheet :>

page presentation page content

In this way the one style sheet can be applied to a range of pages.
This separation of presentation from content has four advantages:

o consistency —there is a uniform appearance across all of the pages; each bullet point, each heading and
each paragraph will look the same

o efficiency —if you wish to make any change to formatting, the only change that has to be made is in the
style sheet; this one change will automatically apply (or cascade through) to all pages that use it

o smaller file size — as the formatting information is stored in one place this avoids repetition; each individual
page can be smaller and take less time to download
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o increased control and flexibility — by localizing the specification of presentation characteristics to one file,
management is more direct and adaptable.
Cascading style sheets can be prepared from within a web page, as we did in this activity, by creating rules as we go
and saving, or a CSS can be written from scratch (File > New > CSS). Dreamweaver Help will explain how to design
your own CSS if you wish to do so.

Alternatives to CSS

In addition to cascading style sheets we could use an internal style sheet, or inline styles.

An internal style sheet is formatting information for an individual page. Internal style rules are recorded near the top
of the HTML code in the <head> section (see step 4e above).

fspit | i Desgn | 7] Live View|v | /] o Tite: Sports

<style type="text/css">

.sp_title {
font-family: Verdana, Geneva, sans-serif;
font-size: xx-large;
color: $00F;
font-weight: bold;
1

</style>
</head>

They indicate how this individual page is to be displayed.
Inline styles vary an HTML tag for an individual element of a page, e.g.
<p style="font-family:times; color:green">.
These style variations are stored as part of the normal HTML code. Inline styles are rarely used nowadays other than
to define how a specific item is to be displayed.
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Of the three (CSS, internal, or inline styles) cascading style sheets are the best to use, especially if you are making
more than one web page.

Fonts

In setting style rules, or using the formatting generally, you may have noticed that you do not have as much choice in
fonts in Dreamweaver as you would have in other programs, such as Word. The reason for this is that there is no
guarantee that the font you choose on the computer to create a page will be available on the computer the page is
seen on. This gives you less control of the final appearance, and even layout, of a page as it will appear on other
computers.

Dreamweaver only offers the most commonly available fonts.

Font BN RN

e Default Font
Verdana, Geneva, sans-serif
Georgia, Times New Roman, Tir , serff
Courier New, Courier, monospace

Arial, Helvetica, sans-serif
Tahoma, Geneva, sans-serif

In the example highlighted above the browser that views your webpage will try to apply the Verdana font. If that is
not available it will try for Geneva or, failing that, any other available san serif font.

In this way you will have a good chance of any browser on any computer presenting text as you had hoped to display
it.
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Activity 3 - Words with style

Shortly we wil look at how to make a whole web site, but before we get to that let’s look at simply setting up a single
‘web page and adding content to it. We will see how to enter the text of the page and how to apply HTML and style
rulesto format it.

To do this we will make a single page with information for a sports” store.
1. a  InDreamweaver close any pages that might be open. (Click on X on each page tab, or use File > Close All)
b Use the Files panel to switch to the Sports Store site.

Thisis a site with no pages yet, just some images and text ready to be used.
¢ Create anew blank HTML page.
“This can be done from the Welcome screen by choosing HTML under Create New.

Create New

.
cosrerl")
If the Welcome screen is not displayed (it can be turned off in Edit > Preferences) then from the menu use

File > New. In the dialogue that appears choose a Blank Page, HTML page type and <none> for layout. When
ready click on Create at lower right.
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Give the page the title of Sports and save it as sports. html.

I ]
L e T

The page will appear in the Files panel in the Sports Store root folder.

Note:

is important that all of the files, images and resources used in a site are kept in the one folder. This
is 50 that when the site is published to a web server they are all available from the one location.
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We will now add text to this page. This can be done in three ways, typing directly into the document window,
importing text, or with a cut and paste from another application.

We will use each of these methods in turn to demonstrate.
a  The easiest, but slowest, way of getting text on a page is to enter it directly.
Make up your own name for the sports’ store and type it in the document window.
s [
2] Code | =3} spit | L4 Desigr

Sportz World
Do not worry about formatting this title yet, we wil get to that shortly.

b While we can type directly into the document window this will take some effort. To save time we will now.
to import some pre-prepared text on sale items for the sports’ store.

Click just after your title and press Enter to move to a new line. — =
Drag the file sale.txt from the files panel onto the document window. Position it :E: Ste - Unnamed s,

just under the store name, and release it 5B mages
When prompted to insert the contents click OK. (Accept the default of Text with ) el &
structure.)

[ E—

oo [ -
! e—
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Sporz World
US—

exersse bikes - fom $125

&

The text from the file will be placed under the title.

€ The third way we can enter text into the document window is to copy it from another application. We
copy some text from Word.

Start Word and, from the Sports Store folder, open the file Special offer.docx.

rowing machines — rom $19¢
rendmils— from $175
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Special offer
“The irat 30 customers into the store his weekend willreceive voucher entiting

them to.anextra 15% of the price o any item in store. Tn addition any of our

<port's club members wil eceive their usual 3% of. Be earyand fake advantage of
these fantasticoffers. See you on Saturdoyl

“This i text formatted using bold, italics, a Comic Sans font, and different sized letters.
Select all of the text (Ctri+A on  PC; Cmd+A on a Mac) and copy it (Ctri+C or Cmd+C)).
Switch back to Dreamweaver and move to a new line under the sale items.

If we paste now we will get an exact copy of the Word document. As we do not want the formatting that is
in the document we will copy just the text.

From the menu (or with a right click) choose Edit > Paste Special... to see the options available.
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